Do any of the following apply to you?

  • When I tap "Connect to ELD" when my Bluetooth is on, it tells me no devices or ELDs were found;
  • When I open Bluetooth settings, I cannot find my Super ELD;
  • When I open Bluetooth settings, I see an entry for "IOSiX ELD" but when I tap on it I am not able to pair;
  • If any of these bullet points apply to you, continue to Step 1.

Step 1: Turning Everything Off

Follow each step carefully.

  • A.) Turn off Bluetooth on all devices in your truck. Check all phones, all tablets- anything in your vehicle that could be interfering with the ELD signal.
  • B.) Turn off your Engine. Completely off, key out of the ignition.
  • C.) Unplug the ELD from your diagnostic port / ECM.
  • D.) Close the Super Dispatch app on your phone / tablet.

Now, double-check you have done all of the above steps. Then:

Step 2: Resetting Everything

  • A.) Turn on your truck engine. Engine completely on, ready to start driving.
  • B.) Plug your ELD back in. Ensure it is seated well.
  • C.) Turn on Bluetooth on your device. After you do, close Settings.
  • D.) Open the Super Dispatch app. Then tap on HoS.

Step 3: Setting Everything Back Up

  • A.) Tap on your vehicle at the top of this page. Now, tap on "Connect to ELD"
  • B.) Your app will scan, using Bluetooth, for your ELD. Often, it will not show up during your first search. Please tap the refresh button in the top right.
  • C.) Once a device is listed that is a variation of "30aea4a7b2ee" you've found it!
  • D.) Now, tap on that device and after 5 seconds, you are connected! You will know you're connected if you see a black checkmark by this device, or if on the HoS tab the [ELD] box is green.

Did this fix your problem? If not, please contact support.

Did this answer your question?